no devices shown on ipad

Homepage Forums Support PULL support no devices shown on ipad

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #3130

    hey man! I`m very frustrated! ive followed every step in your instructions but my ipad doesnt display any devices just the hold, refresh and pull buttons. Ive even tried to load the template with the .jzml file (the one that fits the editor)
    i dont know how to change the port on the ipad. it is set to 8000 and this is not working but i donT know how to change it to 8004.
    please help!


    Hi Andreas

    It sounds like your IP addresses are incorrect. All the IP’s should be on the same network. e.g.

    Mac/PC –
    Router –
    iPad/Lemur –

    Its probably best to just start with a blank screen on the lemur, until you figure out how to get the lemur/max device communicating properly (ie dont try to load the one that fits the editor just yet, instead load the “Large Template” by clicking the button on the Max Device.

    The port on the Lemur and Max Device should be the same 8004. Go into settings of the Lemur (in right hand corner), then you can see two IP addresses/ports in “OSC target” You can’t change the IP/Port on the left (that’s your iPad/Lemur address) , you can change the IP underneath that (to the right, in the middle of the screen) and the port to the right of it. In here you put the IP address for your MAC, or PC and the port 8004.

    If it’s still not working, try right clicking on the top of the max device and select “open max window”, do you see any errors in there?

    Also, which version of Max 6.1 do you have? Are you on a Mac or PC? Are you sure you merged the files properly?

    You’re welcome to contact our support email if thats easier on, support[at]xmonsta[dot]com


    Glad to see Andreas got this solved over support email. It seemed to be an issue that the IP address of the Lemur wasn’t getting it’s automatic (DHCP) address from the router properly. This often results in an IP address like 169.254.x.x , when it should be 192.168.x.x


    hey there,

    i am used to setting up lemur using adhoc networks on mac. right now i can’t get anything to work either. i actually do get 169.254.x.x IP’s. should i try it through a router?


    Hi Tim,

    If you’re getting the 169.254.x.x. problem, then the iPad is not getting its DHCP address automatically assigned. This is pretty common on MAC/iPad wifi connections. I tend to set all adhoc connections manually for this reason.

    If you check the IP of the computer that you’re trying to connect to (MAC) and use that IP address, but changing the last digit (by setting it manually in iPad Wifi settings), it should connect. On a MAC you’ll also want to use for the subnet (this is usually on windows)

    So your MAC IP is:

    Then your iPad IP should be set manually to:

    Also, if needed set a 5 character WEP encrypted password – WPA never really works.

    It might be best to use a router with this software, because so little information is being sent, that an adhoc connection is probably not needed.

    Hope it helps.


    the IP thats displayed in the network preferences of the mac after establishing an adhoc network also starts with 169.

    is that the one that needs to be put into the lemur OSC target settings, next to “host”? like, digit by digit?

    in the iPad network settings i can’t change the IP. theres just blank fields.

    thing is, i can send templates from the editor to the iPad, so a midi connection is def established.

    i must be missing something very obvious…


    OK i got it now. my lemurs IP seems to have the port “built in” by looking like this: 192.254.xx.xx:8000

    i switched everything to port 8000 and now it works. thx for help


    Sounds like you got it, but probably a few things to note. This software uses OSC, over a UDP connection (not Midi, except for the Drum Rack template).

    There are two ip addresses in the Lemur, one on the left (this is your iPad address which is picked up automatically and cannot be changed), and one in the middle/bottom, this one can be changed and should be exactly the same as your MAC/PC ip address. There should also be a port next to it that can be changed. This port should be the same as on your PULL v1.0.amxd We recommend to use 8004 for this port. I don’t think you can use 8000 for this port, because the default incoming port for Lemur is 8000 and I’m not sure you can use the same port for both (but you might be able to). Just for good measure, I would recommend to have 8004 on your Lemur right hand side port and 8004 on the PULL v1.0.amxd device.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.